<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />

<meta property="og:type" content="article" />

<meta property="og:image" content="http://lovefm.com/wp-content/uploads/2017/03/Rubi-Briceno-150x150.jpg" />

<style>
table#gridtable {
    border-collapse: collapse;
    border-color: #666666;
    border-width: 1px;
    color: #333333;
    font-size: 11px;
}
table#gridtable td {
    background-color: #ffffff;
    border-color: #666666;
    border-style: solid;
    border-width: 1px;
    padding: 8px;
}
</style>

<title>

  Physical Therapist Perishes in Traffic Incident - Love FM &#8211; News &amp; Music Power
</title>



<!--<link rel="stylesheet" type="text/css" media="all" href="http://lovefm.com/wp-content/themes/resportsive/style.css" />-->
<link rel="stylesheet" type="text/css" media="screen, projection" href="http://lovefm.com/wp-content/themes/resportsive/style.css?1446668545"  />

<link rel="shortcut icon" href="http://lovefm.com/wp-content/uploads/2015/05/16x16-heart-red-valentine-icon.png" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://lovefm.com/feed/" />

<link rel="alternate" type="text/xml" title="RSS .92" href="http://lovefm.com/feed/rss/" />

<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://lovefm.com/feed/atom/" />

<link rel="pingback" href="http://lovefm.com/xmlrpc.php" />




<link rel="stylesheet" id="wp-forecast-css" href="http://lovefm.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" />

<style type='text/css'>li.lgf-item{width:166px;} li.lgi-item{width:166px}</style>
		<style type="text/css">
			li.lazyest_random, li.lazyest_recent { list-style-type: none; }
			.lazyest_random_slideshow_item, .lazyest_recent_slideshow_item { position:relative }
			.lazyest_random_slideshow_item div.lg_thumb, .lazyest_recent_slideshow_item div.lg_thumb { position:absolute; top:0; left:0; z-index:8; }
			.lazyest_random_slideshow_item div.lg_thumb.active, .lazyest_recent_slideshow_item div.lg_thumb.active { z-index:10; }
			.lazyest_random_slideshow_item div.lg_thumb.last-active, .lazyest_recent_slideshow_item div.lg_thumb.last-active { z-index:9; }
			.lazyest_recent_slideshow_item span.args { display: none; }
		</style>
		<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Love FM - News &amp; Music Power &raquo; Feed" href="http://lovefm.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Love FM - News &amp; Music Power &raquo; Comments Feed" href="http://lovefm.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/lovefm.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bwp-rc-css'  href='http://lovefm.com/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='gallery-bank.css-css'  href='http://lovefm.com/wp-content/plugins/gallery-bank/assets/css/gallery-bank.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='pretty-photo.css-css'  href='http://lovefm.com/wp-content/plugins/gallery-bank/assets/css/pretty-photo.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_stylesheet-css'  href='http://lovefm.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.2.9' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://lovefm.com/wp-includes/css/dashicons.min.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='http://lovefm.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.2.9' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://lovefm.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-au-css'  href='http://lovefm.com/wp-content/plugins/youtube-channel/assets/lib/magnific-popup/magnific-popup.min.css?ver=3.0.10.5' type='text/css' media='all' />
<link rel='stylesheet' id='youtube-channel-css'  href='http://lovefm.com/wp-content/plugins/youtube-channel/assets/css/youtube-channel.css?ver=3.0.10.5' type='text/css' media='all' />
<link rel='stylesheet' id='lazyest-style_0-css'  href='http://lovefm.com/wp-content/plugins/lazyest-gallery/themes/lazyest-style.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='lazyest-style_1-css'  href='http://lovefm.com/wp-content/plugins/lazyest-gallery/css/_slideshow.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='lazyest-style_2-css'  href='http://lovefm.com/wp-content/plugins/lazyest-gallery/css/_ajax.css?ver=4.7.3' type='text/css' media='all' />
<script type='text/javascript' src='http://lovefm.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://lovefm.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/plugins/gallery-bank/assets/js/jquery.masonry.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/plugins/gallery-bank/assets/js/isotope.pkgd.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/plugins/gallery-bank/assets/js/img-liquid.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/plugins/gallery-bank/assets/js/jquery.pretty-photo.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/plugins/wp-forecast/wpf_update.js?ver=9999'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/themes/resportsive/js/jquery.flexslider.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/themes/resportsive/js/jquery.elastislide.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/themes/resportsive/js/scripts.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/themes/resportsive/js/ticker.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/themes/resportsive/js/respond.min.js?ver=4.7.3'></script>
<link rel='https://api.w.org/' href='http://lovefm.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://lovefm.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://lovefm.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Education Minister Speaks of UB&#8217;s Presidency' href='http://lovefm.com/2017/03/09/education-minister-speaks-of-ubs-presidency/' />
<meta name="generator" content="WordPress 4.7.3" />
<link rel="canonical" href="http://lovefm.com/2017/03/09/physical-therapist-perishes-in-traffic-incident/" />
<link rel='shortlink' href='http://lovefm.com/?p=12558' />
<link rel="alternate" type="application/json+oembed" href="http://lovefm.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flovefm.com%2F2017%2F03%2F09%2Fphysical-therapist-perishes-in-traffic-incident%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://lovefm.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flovefm.com%2F2017%2F03%2F09%2Fphysical-therapist-perishes-in-traffic-incident%2F&#038;format=xml" />



</head>



<body class="post-template-default single single-post postid-12558 single-format-standard">



<div id="site">

	<div id="header-top-wrapper">

		<div id="header-top">

			<div id="header-top-left">

				<div class="menu"><ul>
<li class="page_item page-item-15"><a href="http://lovefm.com/about/">About</a></li>
<li class="page_item page-item-19"><a href="http://lovefm.com/contact-us/">Contact us</a></li>
<li class="page_item page-item-17"><a href="http://lovefm.com/on-air-schedule/">On-Air Schedule</a></li>
<li class="page_item page-item-3294"><a href="http://lovefm.com/elections-2015/video-gallery/">Video Gallery</a></li>
<li class="page_item page-item-3241"><a href="http://lovefm.com/elections-2015/voter-turnout-statistics/">Voter Turnout Statistics</a></li>
<li class="page_item page-item-3344"><a href="http://lovefm.com/elections-2015/voting-results/">Voting Results</a></li>
</ul></div>

			</div><!--header-top-left-->

			<div id="header-top-right">

				<form method="get" id="searchform" action="http://lovefm.com/">
	<input type="text" name="s" id="s" value="Search site" onfocus='if (this.value == "Search site") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search site"; }' />
	<input type="hidden" id="search-button" />
</form>
			</div><!--header-top-right-->

		</div><!--header-top-->

	</div><!--header-top-wrapper-->

	<div id="header-wrapper">

		<div id="header">

			<div id="header-contain">

				<div id="header-bottom">

					<div id="logo">

						
						<a href="http://lovefm.com"><img src="http://lovefm.com/wp-content/uploads/2015/05/lovefm-logo2.png" alt="Love FM &#8211; News &amp; Music Power" /></a>

						
					</div><!--logo-->

					
					<div id="news-ticker">

						<ul id="ticker">

							
							<li><a href="http://lovefm.com/2017/03/09/physical-therapist-perishes-in-traffic-incident/">Physical Therapist Perishes in Traffic Incident</a></li>

							
							<li><a href="http://lovefm.com/2017/03/09/education-minister-speaks-of-ubs-presidency/">Education Minister Speaks of UB&#8217;s Presidency</a></li>

							
							<li><a href="http://lovefm.com/2017/03/09/bcg-lieutenant-in-dc-for-a-military-gender-perspective/">BCG Lieutenant in DC For A Military Gender Perspective</a></li>

							
							<li><a href="http://lovefm.com/2017/03/09/chaa-creek-captures-world-legacy-award/">Chaa Creek Captures World Legacy Award</a></li>

							
							<li><a href="http://lovefm.com/2017/03/09/petillo-to-face-murder-trial-in-june/">Petillo to Face Murder Trial in June</a></li>

							
							<li><a href="http://lovefm.com/2017/03/09/forman-escapes-confinement-for-drug-trafficking/">Forman Escapes Confinement for Drug Trafficking</a></li>

							
							<li><a href="http://lovefm.com/2017/03/09/michelle-montejo-to-be-hosted-at-buckingham-palace/">Michelle Montejo to be Hosted at Buckingham Palace</a></li>

							
							<li><a href="http://lovefm.com/2017/03/09/traffic-incident-kills-one-and-injures-two/">Traffic Incident Kills One and Injures Two</a></li>

							
							<li><a href="http://lovefm.com/2017/03/08/12533/"></a></li>

							
							<li><a href="http://lovefm.com/2017/03/07/one-green-planet-petitions-for-protection-of-belize-barrier-reef/">One Green Planet Petitions for Protection of Belize Barrier Reef</a></li>

							
						</ul>

					</div><!--news-ticker-->

								

				</div><!--header-bottom-->

				<div id="nav-main">

					<div class="menu-topmenu-container"><ul id="menu-topmenu" class="menu"><li id="menu-item-3300" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-3300"><a href="http://lovefm.com/">Home</a></li>
<li id="menu-item-3299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3299"><a href="http://lovefm.com/about/">About</a></li>
<li id="menu-item-3298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3298"><a href="http://lovefm.com/on-air-schedule/">On-Air Schedule</a></li>
<li id="menu-item-3297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3297"><a href="http://lovefm.com/contact-us/">Contact us</a></li>
</ul></div>
				</div><!--nav-main-->

				<div id="nav-mobi">

					<div class="flip">Menu</div>

					<div class="panel"><div class="menu-topmenu-container"><ul id="menu-topmenu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-3300"><a href="http://lovefm.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3299"><a href="http://lovefm.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3298"><a href="http://lovefm.com/on-air-schedule/">On-Air Schedule</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3297"><a href="http://lovefm.com/contact-us/">Contact us</a></li>
</ul></div></div>

				</div><!--nav-mobi-->

			</div><!--header-contain-->

		</div><!--header-->

	</div><!--header-wrapper-->

	<div id="wrapper">

		<div id="wrapper-inner">

			
				<div id="content">
<div id="main">
	<div id="post-area" class="post-12531 post type-post status-publish format-standard has-post-thumbnail hentry category-belize-barrier-reef category-environment category-oil-exploration tag-headlines">
				<div class="breadcrumb">
			<div id="crumbs"><a href="http://lovefm.com">Home</a>  /  <a href="http://lovefm.com/category/accident/">Accident</a>  /  <span class="current">Physical Therapist Perishes in Traffic Incident</span></div>		</div><!--breadcrumb-->

		<h1 class="headline">Physical Therapist Perishes in Traffic Incident</h1>

		<div id="post-info">
			<div id="post-info-left">
				By <a href="http://lovefm.com/author/lovefm/" title="Posts by Renee Trujillo" rel="author">Renee Trujillo</a>			</div><!--post-info-left-->
			<div id="post-info-right">
				Updated: March 9, 2017			</div><!--post-info-right-->
		</div><!--post-info-->

		<div id="social-box">
			<div class="post-social-horz">
				<iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Flovefm.com%2F2017%2F03%2F09%2Fphysical-therapist-perishes-in-traffic-incident%2F&amp;layout=button_count&amp;show_faces=false&amp;width=100&amp;action=like&amp;colorscheme=light" scrolling="no" frameborder="0" allowTransparency="true" style="border:none; overflow:hidden; width:100px; height:20px;">
</iframe>

			</div><!--post-social-horz-->
			<div class="post-social-horz">

				<a href="http://twitter.com/share" class="twitter-share-button" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script>

			</div><!--post-social-horz-->

			<div class="post-social-horz">

				<g:plusone size="medium" annotation="inline" width="120"></g:plusone>

			</div><!--post-social-horz-->

		</div><!--social-box-->

		<div id="social-box-vert">

			<div class="post-social-vert">

				<iframe src="http://www.facebook.com/plugins/like.php?&amp;href=http%3A%2F%2Flovefm.com%2F2017%2F03%2F09%2Fphysical-therapist-perishes-in-traffic-incident%2F&amp;send=false&amp;layout=box_count&amp;width=450&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font&amp;height=90" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:50px; height:60px;" allowTransparency="true"></iframe>

			</div><!--post-social-vert-->

			<div class="post-social-vert">

				<a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-count="vertical">Tweet</a>

			</div><!--post-social-vert-->

			<div class="post-social-vert">

				<g:plusone size="tall"></g:plusone>

			</div><!--post-social-vert-->

		</div><!--social-box-vert-->

		<div id="content-area">

								<img width="610" height="400" src="http://lovefm.com/wp-content/uploads/2017/03/Rubi-Briceno.jpg" class="attachment-post-thumb size-post-thumb wp-post-image" alt="" srcset="http://lovefm.com/wp-content/uploads/2017/03/Rubi-Briceno.jpg 610w, http://lovefm.com/wp-content/uploads/2017/03/Rubi-Briceno-300x197.jpg 300w, http://lovefm.com/wp-content/uploads/2017/03/Rubi-Briceno-145x95.jpg 145w" sizes="(max-width: 610px) 100vw, 610px" />							<p>An afternoon road traffic accident on the Stann Creek Valley Road claimed the life of 33-year-old Rubia Analicia Briceno. According to Police, the incident occurred at mile nine on the Stann Creek Valley Road where they saw a white pickup truck in a ditch with its four wheels up in the air. They also saw a white Toyota Hilux parked on a feeder road. Initial investigations reveal that 31-year-old Leon Peters, who was driving the pickup truck was along with Briceno when there was a collision with the Hilux driven by Leon Peters Senior. The impact caused Briceno to be thrown from the vehicle. She was taken to the Southern Regional Hospital where she later succumbed to the injuries. Both drivers were served with a notice of intended prosecution.</p>
				</div>
		<div class="post-tags"><a href="http://lovefm.com/tag/headlines/" rel="tag">Headlines</a></div>
		<div class="breaker"></div>
		
            <div class="small-cat">
            <h2 class="section top-20"><span class="section">Related Posts</span></h2>
		<div class="small-cat-story"><ul>
            
            <li>
                <div class="img-story">
			
			<a href="http://lovefm.com/2017/03/09/education-minister-speaks-of-ubs-presidency/" rel="bookmark" title="Education Minister Speaks of UB&#8217;s Presidency" class="img-shadow"><img width="145" height="95" src="http://lovefm.com/wp-content/uploads/2016/11/PatrickFaber-MoE-145x95.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" srcset="http://lovefm.com/wp-content/uploads/2016/11/PatrickFaber-MoE-145x95.jpg 145w, http://lovefm.com/wp-content/uploads/2016/11/PatrickFaber-MoE-300x197.jpg 300w, http://lovefm.com/wp-content/uploads/2016/11/PatrickFaber-MoE.jpg 610w" sizes="(max-width: 145px) 100vw, 145px" /></a>
			
		</div><!--img-story-->
		<a href="http://lovefm.com/2017/03/09/education-minister-speaks-of-ubs-presidency/" rel="bookmark">Education Minister Speaks of UB&#8217;s Presidency</a>
            </li>
            
            <li>
                <div class="img-story">
			
			<a href="http://lovefm.com/2017/03/09/bcg-lieutenant-in-dc-for-a-military-gender-perspective/" rel="bookmark" title="BCG Lieutenant in DC For A Military Gender Perspective" class="img-shadow"><img width="145" height="95" src="http://lovefm.com/wp-content/uploads/2017/03/Almita-Pinelo-145x95.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" srcset="http://lovefm.com/wp-content/uploads/2017/03/Almita-Pinelo-145x95.jpg 145w, http://lovefm.com/wp-content/uploads/2017/03/Almita-Pinelo-300x197.jpg 300w, http://lovefm.com/wp-content/uploads/2017/03/Almita-Pinelo.jpg 610w" sizes="(max-width: 145px) 100vw, 145px" /></a>
			
		</div><!--img-story-->
		<a href="http://lovefm.com/2017/03/09/bcg-lieutenant-in-dc-for-a-military-gender-perspective/" rel="bookmark">BCG Lieutenant in DC For A Military Gender Perspective</a>
            </li>
            
            <li>
                <div class="img-story">
			
			<a href="http://lovefm.com/2017/03/09/chaa-creek-captures-world-legacy-award/" rel="bookmark" title="Chaa Creek Captures World Legacy Award" class="img-shadow"><img width="145" height="95" src="http://lovefm.com/wp-content/uploads/2017/03/Chaa-Creek-145x95.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" srcset="http://lovefm.com/wp-content/uploads/2017/03/Chaa-Creek-145x95.jpg 145w, http://lovefm.com/wp-content/uploads/2017/03/Chaa-Creek-300x197.jpg 300w, http://lovefm.com/wp-content/uploads/2017/03/Chaa-Creek.jpg 610w" sizes="(max-width: 145px) 100vw, 145px" /></a>
			
		</div><!--img-story-->
		<a href="http://lovefm.com/2017/03/09/chaa-creek-captures-world-legacy-award/" rel="bookmark">Chaa Creek Captures World Legacy Award</a>
            </li>
            
            <li>
                <div class="img-story">
			
			<a href="http://lovefm.com/2017/03/09/petillo-to-face-murder-trial-in-june/" rel="bookmark" title="Petillo to Face Murder Trial in June" class="img-shadow"><img width="145" height="95" src="http://lovefm.com/wp-content/uploads/2017/03/Ronlee-Petillo-145x95.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" srcset="http://lovefm.com/wp-content/uploads/2017/03/Ronlee-Petillo-145x95.jpg 145w, http://lovefm.com/wp-content/uploads/2017/03/Ronlee-Petillo-300x197.jpg 300w, http://lovefm.com/wp-content/uploads/2017/03/Ronlee-Petillo.jpg 610w" sizes="(max-width: 145px) 100vw, 145px" /></a>
			
		</div><!--img-story-->
		<a href="http://lovefm.com/2017/03/09/petillo-to-face-murder-trial-in-june/" rel="bookmark">Petillo to Face Murder Trial in June</a>
            </li>
            </ul></div></div>			<div id="comments">
				
	

</div><!--comments-->		
	</div><!--post-area-->

</div><!--main -->



<div id="sidebar-container">

	<div class="sidebar-widget"><h3 class="widget"><span class="widget">Radio Stream</span></h3>			<div class="textwidget"><a class="btnListen" href="http://www.digicell.bz/belize-web" target="_blank">Listen Live</a></div>
		</div><div class="sidebar-widget"><h3 class="widget"><span class="widget">Archives</span></h3>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://lovefm.com/2017/03/'> March 2017 &nbsp;(47)</option>
	<option value='http://lovefm.com/2017/02/'> February 2017 &nbsp;(196)</option>
	<option value='http://lovefm.com/2017/01/'> January 2017 &nbsp;(208)</option>
	<option value='http://lovefm.com/2016/12/'> December 2016 &nbsp;(169)</option>
	<option value='http://lovefm.com/2016/11/'> November 2016 &nbsp;(138)</option>
	<option value='http://lovefm.com/2016/10/'> October 2016 &nbsp;(208)</option>
	<option value='http://lovefm.com/2016/09/'> September 2016 &nbsp;(148)</option>
	<option value='http://lovefm.com/2016/08/'> August 2016 &nbsp;(113)</option>
	<option value='http://lovefm.com/2016/07/'> July 2016 &nbsp;(145)</option>
	<option value='http://lovefm.com/2016/06/'> June 2016 &nbsp;(175)</option>
	<option value='http://lovefm.com/2016/05/'> May 2016 &nbsp;(211)</option>
	<option value='http://lovefm.com/2016/04/'> April 2016 &nbsp;(235)</option>
	<option value='http://lovefm.com/2016/03/'> March 2016 &nbsp;(187)</option>
	<option value='http://lovefm.com/2016/02/'> February 2016 &nbsp;(250)</option>
	<option value='http://lovefm.com/2016/01/'> January 2016 &nbsp;(226)</option>
	<option value='http://lovefm.com/2015/12/'> December 2015 &nbsp;(152)</option>
	<option value='http://lovefm.com/2015/11/'> November 2015 &nbsp;(146)</option>
	<option value='http://lovefm.com/2015/10/'> October 2015 &nbsp;(145)</option>
	<option value='http://lovefm.com/2015/09/'> September 2015 &nbsp;(169)</option>
	<option value='http://lovefm.com/2015/08/'> August 2015 &nbsp;(199)</option>
	<option value='http://lovefm.com/2015/07/'> July 2015 &nbsp;(173)</option>
	<option value='http://lovefm.com/2015/06/'> June 2015 &nbsp;(185)</option>
	<option value='http://lovefm.com/2015/05/'> May 2015 &nbsp;(73)</option>

		</select>
		</div><div class="sidebar-widget">			<div class="textwidget"><a href="http://lovefm.com/elections-2015/"><img src="http://lovefm.com/wp-content/uploads/2015/10/love-fm-web-banner1.png" alt="Coming Soon Nov, 4 2015 - The People Speak!" /></a></div>
		</div>		<div class="sidebar-widget">		<h3 class="widget"><span class="widget">Recent News</span></h3>		<ul>
					<li>
				<a href="http://lovefm.com/2017/03/09/physical-therapist-perishes-in-traffic-incident/">Physical Therapist Perishes in Traffic Incident</a>
							<span class="post-date">March 9, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/09/education-minister-speaks-of-ubs-presidency/">Education Minister Speaks of UB&#8217;s Presidency</a>
							<span class="post-date">March 9, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/09/bcg-lieutenant-in-dc-for-a-military-gender-perspective/">BCG Lieutenant in DC For A Military Gender Perspective</a>
							<span class="post-date">March 9, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/09/chaa-creek-captures-world-legacy-award/">Chaa Creek Captures World Legacy Award</a>
							<span class="post-date">March 9, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/09/petillo-to-face-murder-trial-in-june/">Petillo to Face Murder Trial in June</a>
							<span class="post-date">March 9, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/09/forman-escapes-confinement-for-drug-trafficking/">Forman Escapes Confinement for Drug Trafficking</a>
							<span class="post-date">March 9, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/09/michelle-montejo-to-be-hosted-at-buckingham-palace/">Michelle Montejo to be Hosted at Buckingham Palace</a>
							<span class="post-date">March 9, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/09/traffic-incident-kills-one-and-injures-two/">Traffic Incident Kills One and Injures Two</a>
							<span class="post-date">March 9, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/08/food-vendor-charged-with-attempted-murder/">Food Vendor Charged with Attempted Murder</a>
							<span class="post-date">March 8, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/08/12533/">12533</a>
							<span class="post-date">March 8, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/07/one-green-planet-petitions-for-protection-of-belize-barrier-reef/">One Green Planet Petitions for Protection of Belize Barrier Reef</a>
							<span class="post-date">March 7, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/07/remembering-belizes-heroes-and-benefactors/">Remembering Belize&#8217;s Heroes and Benefactors</a>
							<span class="post-date">March 7, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/teenager-found-dead-out-west/">Teenager Found Dead Out West</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/fatal-traffic-incident-on-the-southern-road/">Fatal Traffic Incident on the Southern Road</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/day-1-la-ruta-maya-river-challenge-2017/">Day 1 &#8211; La Ruta Maya River Challenge 2017</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/pup-parliamentarians-excluded-from-natl-executive/">PUP Parliamentarians Excluded from Nat&#8217;l Executive</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/julius-espat-speaks-of-an-obsession-with-the-lord-ashcroft/">Julius Espat Speaks of An Obsession with the Lord Ashcroft</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/us-embassy-campaigns-against-cyber-bullying/">US Embassy Campaigns Against Cyber Bullying</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/parent-remanded-for-hitting-school-teacher/">Parent Remanded for Hitting School Teacher</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/belmopan-mayor-speaks-of-recently-built-roads/">Belmopan Mayor Speaks of Recently Built Roads</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/exploring-the-world-via-cultures-at-horizon/">Exploring the World via Cultures at Horizon</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/child-stimulation-reading-for-the-preschoolers/">Child Stimulation: Reading for the Preschoolers</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/reggae-and-dancehall-ol-school-combo/">Reggae and Dancehall Ol&#8217; School Combo</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/03/inquiry-revelations-used-to-strengthen-immigration-systems/">Inquiry Revelations Used to Strengthen Immigration Systems</a>
							<span class="post-date">March 3, 2017</span>
						</li>
					<li>
				<a href="http://lovefm.com/2017/03/02/mark-tench-cries-slander-by-ceo-saldivar/">Mark Tench Cries Slander by CEO Saldivar</a>
							<span class="post-date">March 2, 2017</span>
						</li>
				</ul>
		</div>		<div class="sidebar-widget"><h3 class="widget"><span class="widget">Local Weather</span></h3><div id="wp-forecastA" class="wp-forecast">
<div class="wp-forecast-curr">
<div class="wp-forecast-curr-head"><div><a href="http://www.accuweather.com/quick-look.aspx?partner=accuweather&amp;loc=CAC|BZ|BH001|BELIZE&amp;metric=0" target="_blank" >Belize City</a></div>
<div>March 10, 2017, 10:18 am</div>
</div>
<div class="wp-forecast-curr-block"><div class='wp-forecast-curr-left'><img class='wp-forecast-curr-left' src='http://lovefm.com/wp-content/plugins/wp-forecast/icons/06.gif' alt='Mostly cloudy' width='64' height='40' />
<br /></div><div class='wp-forecast-curr-right'><div>Mostly cloudy<br/>81&deg;F</div></div>
</div>
<div class="wp-forecast-curr-details"><div>real feel: 98&deg;F</div>
<div>current pressure: 30 in</div>
<div>humidity: 83%</div>
<div>wind speed: 6 kts E</div>
<div>wind gusts: 6 kts</div>
<div>UV-Index: 4</div>
<div>sunrise: 6:04 am</div>
<div>sunset: 6:01 pm</div>
<div class="wp-forecast-copyright"><a href="http://www.accuweather.com">&copy; 2017 AccuWeather, Inc.</a></div></div>
</div>
<div class="wp-forecast-fc">
<div class="wp-forecast-fc-oneday">
<div class="wp-forecast-fc-head">Forecast March 10, 2017</div>
<div class="wp-forecast-fc-block">
<div class="wp-forecast-fc-left">
<div>day</div>
<img class='wp-forecast-fc-left' src='http://lovefm.com/wp-content/plugins/wp-forecast/icons/14.gif' alt='Partly sunny with showers' width='64' height='40' /><br />
</div>
<div class='wp-forecast-fc-right'><div>Partly sunny with showers</div><div>84&deg;F</div><div>wind speed: 6 kts ENE</div><div>wind gusts: 8 kts</div>
<div>max. UV-Index: 10</div>
</div></div>
<div class="wp-forecast-fc-block">
<div class="wp-forecast-fc-left">
<div>night</div>
<img class='wp-forecast-fc-left' src='http://lovefm.com/wp-content/plugins/wp-forecast/icons/35.gif' alt='Partly cloudy' width='64' height='40' /><br />
</div>
<div class='wp-forecast-fc-right'><div>Partly cloudy</div><div>75&deg;F</div><div>wind speed: 4 kts E</div><div>wind gusts: 8 kts</div>
<div>max. UV-Index: 10</div>
</div></div>
</div>
</div>
</div>
<div style="clear:inherit;">&nbsp;</div></div><div class="sidebar-widget"><h3 class="widget"><span class="widget">Facebook Fans</span></h3>
		<div class="widget-fb">

			<iframe src="//www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/pages/Love-FM-News-and-Music-Power/114262182112994&amp;width=300&amp;height=258&amp;show_faces=true&amp;colorscheme=light&amp;stream=false&amp;border_color=%23ffffff&amp;header=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300; height:258px;" allowTransparency="true"></iframe>

		</div>


		</div>
</div><!--sidebar-container-->
</div><!--content-->

<div id="footer">
	<div class="footer-widget"><h3>Advertise with us</h3>			<div class="textwidget">Love FM prides itself in having several programs that attract various audiences. You will find that our rates for advertising will definitely be worth the publicity and attention your business/project demands. Contact our sales persons at your convenience: Martha Montero 501-631-4859, Terry Gordon 501-610-1484, Renira Pollard 501-610-6472</div>
		</div>
</div><!--footer-->
<div id="footer-bottom">
	<div id="footer-nav1">
		<div class="menu-topmenu-container"><ul id="menu-topmenu-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-3300"><a href="http://lovefm.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3299"><a href="http://lovefm.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3298"><a href="http://lovefm.com/on-air-schedule/">On-Air Schedule</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3297"><a href="http://lovefm.com/contact-us/">Contact us</a></li>
</ul></div>
	</div><!--footer-nav1-->
	<div id="footer-nav2">
		<div class="menu"><ul>
<li class="page_item page-item-15"><a href="http://lovefm.com/about/">About</a></li>
<li class="page_item page-item-19"><a href="http://lovefm.com/contact-us/">Contact us</a></li>
<li class="page_item page-item-17"><a href="http://lovefm.com/on-air-schedule/">On-Air Schedule</a></li>
<li class="page_item page-item-3294"><a href="http://lovefm.com/elections-2015/video-gallery/">Video Gallery</a></li>
<li class="page_item page-item-3241"><a href="http://lovefm.com/elections-2015/voter-turnout-statistics/">Voter Turnout Statistics</a></li>
<li class="page_item page-item-3344"><a href="http://lovefm.com/elections-2015/voting-results/">Voting Results</a></li>
</ul></div>

	</div><!--footer-nav2-->
	<div id="footer-info">
		Copyright © 2015 LoveFM.com
	</div><!--footer-info-->
</div><!--footer-bottom-->

</div><!--wrapper-inner-->
</div><!--wrapper-->
</div><!--site-->

<!-- YouTube Channel 3 --><script type="text/javascript">function ytc_init_MPAU() {jQuery('.ytc-lightbox').magnificPopupAU({disableOn:320,type:'iframe',mainClass:'ytc-mfp-lightbox',removalDelay:160,preloader:false,fixedContentPos:false});}jQuery(window).on('load',function(){ytc_init_MPAU();});jQuery(document).ajaxComplete(function(){ytc_init_MPAU();});</script><script type='text/javascript' src='http://lovefm.com/wp-includes/js/comment-reply.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://lovefm.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='http://lovefm.com/wp-content/plugins/youtube-channel/assets/lib/magnific-popup/jquery.magnific-popup.min.js?ver=3.0.10.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var lazyest_ajax = {"ajaxurl":"http:\/\/lovefm.com\/wp-admin\/admin-ajax.php","searchfor":"Searching for comment...","pleasewait":"Please wait while Lazyest Gallery searches for ","pagination":"default"};
var lazyest_widgets = {"_nonce":"83bc79d97d","ajaxurl":"http:\/\/lovefm.com\/wp-admin\/admin-ajax.php","slideshow_duration":"5000"};
var lazyestshow = {"captionqueue":"2000","captionopcty":"2000","slideview":"1000","duration":"5000"};
var lazyestimg = {"ajaxurl":"http:\/\/lovefm.com\/wp-admin\/admin-ajax.php?"};
/* ]]> */
</script>
<script type='text/javascript' src='http://lovefm.com/wp-content/plugins/lazyest-gallery/js/lazyest-gallery.js?ver=1.1.20'></script>
<script type='text/javascript' src='http://lovefm.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>


<script type="text/javascript">
jQuery(document).ready(function($){
	$(window).load(function() {
	$('.flexslider').flexslider({
	animation: "slide",
	slideshowSpeed: 10000,
	controlsContainer: ".flexslider-container"
	});
	});
});
</script>

<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>

<script type="text/javascript">
jQuery(document).ready(function($){
$('.carousel').elastislide({
	imageW 	: 145,
	minItems	: 2,
	margin		: 10
});
var main_menu=new main_menu.dd("main_menu");
main_menu.init("main_menu","menuhover");
});
</script>



</body>
</html>